XPERIA X10: Akku laden.

4 08 2010

Wie jedes Gadget verlangt auch das X10 regelmäßig nach einer Steckdose um den Akku zu laden.
Dafür wird ein Netzteil mitgeliefert, welches über eine USB-Buchse verfügt. In diese wird das (mitgelieferte) Datenkabel gesteckt und das X10 kann geladen werden.

Hey, wenn das Netzteil eine USB-Buchse hat, dann müsste ich das X10 doch auch an jedem normalen USB-Port aufladen können. Probieren wir es doch einmal aus.
Sobald das Xperia per USB an einen Rechner angeschlossen wird, erscheint das Blitzsymbol auf der Akkuanzeige und signalisiert, dass das Handy geladen wird. Allerdings dauert das Laden per USB länger als direkt am Netzteil. Dies ist dem maximalen Strom der per USB zur Verfügung gestellt wird geschuldet. Ein USB-Anschluss liefert gemäß Definition maximal 500 mA. Dieser Beschränkung ist das Netzteil nicht unterworfen.

Jedoch reicht ein USB-Anschluss der mit Spannung versorgt wird nicht aus. Die USB-Anschlüsse meines Rechners liefern auch im Standby Strom um z.B. ein Handy zu laden – doch das X10 lädt dann nicht. Scheinbar reicht die pure Spannungsversorgung nicht aus – doch dazu gleich mehr.

Wenn ich ja per USB laden kann, dann kann ich das X10 ja auch im Auto laden – schließlich habe ich einen Adapter für die Bordsteckdose / Zigarettenanzünderanschluss. Dieser wandelt die 12V des Autos in 5V um und stellt diese an einem USB-Anschluss zur Verfügung. Doch auch hier will das X10 nicht laden. Ist der Adapter vielleicht kaputt? Schnell ein anderes Telefon angeschlossen – es wird geladen.

ACHTUNG! Ich übernehme keinerlei Haftung für Schäden. Ihr solltet nur dann an der Elektronik rum spielen und rum basteln wenn ihr wisst was ihr da macht. Jegliche Änderung geschieht auf eigene Gefahr! Beachtet auch, dass bei Modifikationen der Elektronik die Garantie des Gerätes erlischt!

Dann analysieren wir doch mal das Netzteil welches Sony Ericsson mitliefert. Wissen macht bekanntlich Ah! Wie ist so ein USB-Anschluss denn nun aufgebaut? Es gibt zwei Adern für die Spannungsversorgung (+5V und GND/Masse) sowie zwei Datenleitungen (D+ und D-) – die Datenleitungen des Netzteils sind kurz geschlossen also miteinander Verbunden.

Verbinde ich nun auch bei dem Autoadapter die Datenleitungen lädt das X10 im Auto ohne Probleme. Dazu wird der Adapter zerlegt und die beiden Kontakte der Leitungen D+ und D- (Pin 2 und Pin 3) kurzgeschlossen.

Werbeanzeigen




Ajaxterm und Firefox 3.6

9 02 2010

Normalerweise habe ich für die Wartung meines Servers und Zugriffe auf Server bei denen ich ab und an mal nach dem Rechten schaue immer Putty dabei. Doch es kann auch mal vorkommen, dass ich – wieso auch immer – kein Programm nutzen kann / darf und auf vorhandene Mittel angewiesen bin.

In diesem Fall habe ich immer noch Ajaxterm. Ein Webinterface welches mit SSH-Zugang auf einen Server anbietet.

Mit dem Update auf Firefox 3.6 funktioniert Ajaxterm allerdings nicht mehr richtig. Grund dafür ist ein Problem mit Sarissa. Sarissa ist eine Javascript-Bibliothek die verschiedenste Funktionen rund um XML implementiert und auch in anderen Webanwendungen genutzt wird. Um größtmögliche Kompatibilität mit den verschiedensten Browsern zu gewährleisten werden an verschiedensten Stellen Variablen innerhalb Sarissa definiert und mit Werten belegt um jede Browservariante zufrieden zu stellen. Allerdings wird von Firefox 3.6 eine dieser Variablendeklaration als Fehler markiert und die Ausführung des Skriptes beendet.

Ein Quick ’n‘ Dirty Hack hilft weiter und die Anwendung funktioniert wieder.

Ajaxterm liefert die Datei „sarissa.js“ mit – in Zeile 269 steht folgende Anweisung:

XMLDocument.prototype.readyState = 0;

Diese Zeile wird einfach auskommentiert und schon ist Firefox wieder zufrieden.

// XMLDocument.prototype.readyState = 0

Dieser Hack ist nicht unbedingt schön und garantiert nicht frei von Nebeneffekten – doch funktioniert Ajaxterm von Haus aus nur mit Firefox ohne größere Komplikationen und somit ist diese Änderung im vertretbaren Rahmen da sie keine Probleme bei Firefox hervor ruft.





Probleme bei Zooomr.

1 02 2008

Meine Fotos und Grafiken hier im Blog sind bei Zooomr gespeichert.

Bei den meisten steht aktuell nur: „SORRY, THIS PHOTO IS CURRENTLY UNAVAILABLE. ZOOOMR ™“.

Aktuell zieht die Technik von Zooomr von den USA nach Japan um.

[2008/2/1 22:35 JST] We got upload and storage back online today; Unfortunately, we weren’t able to activate all photos, but you can bet that we are working hard on moving the remaining hardware from the US to Japan. [..]

Deshalb bitte ich um Verständnis das es noch ein wenig dauern kann bis alles wieder verfügbar ist.